2013/05/19(日)bit.lyのAPI

TwitterがURLの短縮を自動で行うようになったので、あまり使い道がないが、bit.lyを使ってURLを短縮するプログラムをなでしこで書いてみた。既に短縮してあれば、元のURLに変換する。bit.lyのAPIキーはhttps://bitly.com/a/your_api_keyからサインアップして取得できる。

ロングURL=#短縮あるいはデコードするURL
ログインID=#bit.lyのログインID
APIキー=#APIキー
ロングURLを「http://bit.ly/\w.*」で正規表現一致
もし、それが1ならば、
 対象タグは「long_url」
 対象URLは「http://api.bitly.com/v3/expand?shortUrl={ロングURL}&login={ログインID}&apiKey={APIキー}&format=xml」
違えば、
 対象タグは「url」
 対象URLは「http://api.bitly.com/v3/shorten?longUrl={ロングURL}&login={ログインID}&apiKey={APIキー}&format=xml」
経過ダイアログはオフ
エラー監視
 「{対象URL}」をHTTPデータ取得
 bitはそれ
エラーならば、
 「短縮URLを取得できませんでした。」と言う
 戻る
bitで「{対象タグ}」をタグ切り出し
「<{対象タグ}>(.*)</{対象タグ}>」を「$1」に正規表現単置換
短縮URLはそれ

同じ機能の秀丸マクロ・短縮URL作成マクロ は200行以上ある。なでしこだと簡単だ。

OK キャンセル 確認 その他